скрытое меню

Сохранение / восстановление данных форм

Пока знаю только так:

&НаСервере
Процедура ВосстановитьНастройки()
	КлючОбъекта = "7895398764356345634954";
	КлючНастроек = "4e7843767456897565";
	ОписаниеНастроек = "094908453573428578347584";
	ИмяПользователя = "";

	ЗначениеНастроек = ХранилищеОбщихНастроек.Загрузить(КлючОбъекта, КлючНастроек, ОписаниеНастроек, ИмяПользователя);

	Если ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда
		Отчет.начениеНастроек.Получить("Ф");
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	 ВосстановитьНастройки();
КонецПроцедуры	

&НаСервере
Процедура СохранитьНастройки()  

	КлючОбъекта = "7895398764356345634954";
	КлючНастроек = "4e7843767456897565";
	ОписаниеНастроек = "094908453573428578347584";

	ИмяПользователя = "";

	Настройки = Новый Соответствие;
	Настройки.Вставить("Ф", Отчет.Ф);

	ХранилищеОбщихНастроек.Сохранить(КлючОбъекта, КлючНастроек, Настройки, ОписаниеНастроек, ИмяПользователя);
	
КонецПроцедуры  

&НаКлиенте
Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
	  СохранитьНастройки();
КонецПроцедуры 
Яндекс.Метрика